Ford Ranger Forums banner

41 - 60 of 62 Posts

·
Registered
Joined
·
585 Posts
M5OD i believe
 

·
Premium Member
Joined
·
3,321 Posts
workdog said:
Other than a C4, what trans will bolt up to a 4.0?
As for a manual, I believe white94ranger is correct. As for automatic, I believe it's an A4LD.
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #44 ·
The tool box was too big for the Ranger. So its going to go on my trailer.
Hopefully Ill be able to have a garage this Saturday. Going to try and get a Side by Side out of there thats been in there for over a year (wrecked and its taken apart).

Any one ever have good paint work from Macco? I know its probably going to be **** but they got a sale for $299 and I think anything would look better than it does now.
 

·
Premium Member
Joined
·
3,321 Posts
I personally have heard nothing but bad reviews about Maaco. The few cars that I've seen done by our local one were just terrible. The paint was spotted and there was dirt in the paint.
 

·
Registered
Joined
·
901 Posts
What I heard about Maaco is that you have to do all the priming, and well I use to live in a trailer court. About half of it was occupied by Asian Ricers, and you would see most of their cars all primed up, and I've talked to a couple of them about it, and they were sending them to maaco, cause it was cheap. but the before, and after are just too much. I mean they looked better primed.
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #47 ·
What is the line thats below the fuel pressure regulator? Mines got a split in it and is dripping gas down on the valve covers.
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #48 ·
Its goes from rubber hose to a plastic tube (this is where it is leaking from) and then to a connection and then to the manifold
 

·
Registered
Joined
·
1,340 Posts
Without a pic, and a bad memory, I'll guess that it's a vacuum line. There shouldn't be any fuel in there so I'd suspect your fuel pressure regulator is screwed.

Richard
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #50 ·
Ill get some pics in the morning.
If it was the regulator, it wouldn't run right? Shes running fine (for once)
 

·
Registered
Joined
·
1,340 Posts
workdog said:
If it was the regulator, it wouldn't run right?
So I'd think too. I'll look at the pic tomorrow.

Richard
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #53 ·
just got towed home. im starting to hate this truck.
died on me, try to start and it does but dies 2 seconds latter (if that). then after about 1 min it will start again but dies right after. Im thinking clogged fuel filter(s). any other ideas?
 

·
Registered
Joined
·
1,340 Posts
I don't recognize the vacuum lines, I'll have to look at mine tomorrow.
Pull the codes.

Richard
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #55 ·
******! The bastard started. Going to still replace both filters. GOing to try and pump out the 2nd tank because I think that's the problemo.
 

·
Registered
Joined
·
1,340 Posts
I didn't get a chance to look at my truck but was thinking the vacuum line may go to the IAC [idle air control]. IIRC it's on the passenger side of the intake, a cylinder of ~ 2.5cm/1" and ~ 12cm/5" long. It has 2 wires going to it as well as a vacuum line [I think]. They do have problems and it's easy to pull them off and clean them.

Richard
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #57 ·
I think thats the return line because it goes down to the fuel rail. Once the truck has sat for a while it does not leak anymore. Gotta figure out if its just a plastic tube that goes into some rubber line or if the plastic part goes all the way through the line.

Thanks for the help bud
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #58 ·
I think the A4LD is near its breaking point, shifts hard untill its been warm. Going to flush it out this week and put synthetic in and see how that goes. Also the damn trans cooler lines leak. Good thing today was pay day lol
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #59 ·
Got a 3 ft whip for the CB today. Had to build a bracket for it though. Pics tomorrow.
How are people wiring power to their CB's? I ran solid copper wire directly to the battery and I get alot of engine noise. any way to get rid of that?
 

·
Registered
Joined
·
1,340 Posts
Sorry, can't help on the cb wiring. How did the tranny flush go?

Richard
 
41 - 60 of 62 Posts
Top