Ford Ranger Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
1994. pushrod 4.0. Manual 5 speed. Truck sits there and idles well. when i hit the throttle she runs like crap, acts like it wants to die. Anybody have any clue why my truck might be doing this? this is my daily driver right now so I really need to get this figured out asap. Any and all help is greatly appreciated.
Thanks,
Art
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
thats sounds like a miss try checking the coil packs for cracks also a tune up wouldnt be a bad idea.
I have a spark checker I'm getting spark at all the plugs.
Tune up prolly wouldn't hurt it's been about 50k since the last time i did one.

I found an injector o-ring that was leaking fuel, put a new one on, and now im having different symptoms. At idle it will miss intermittently, if i throttle up and then let go it backfires. when i hit the throttle it still runs like crap but not as bad as before. If i gradually throttle up it will throttle up but something is wrong here she still aint happy. and this was an all at once thing, one day it ran fine and then a couple days later this.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I went and bought a MAF sensor, turned the truck on, and.....big difference. I can rev it up and everything I just drove it around. if i really whomp on the throttle and let go it will still backfire but it runs and drives thanks a million to everyone who posted on here to help me.
 
1 - 5 of 5 Posts
Top