Ford Ranger Forums banner

Status
Not open for further replies.
1 - 19 of 19 Posts

·
Registered
Joined
·
585 Posts
Discussion Starter #1
hey guys i went out and finally found a deal on a optima red top battery for my truck, so mabey an hour ago i put it in and i started the truck and it started up fine put there was this pinging noise. what could this be from? right now with that noise it sounds like a desiel.
thanks Dustin
 

·
Registered
Joined
·
1,340 Posts
Hard to tell from your description. Post up a vid with sound.
Richard
 

·
Premium Member
Joined
·
3,321 Posts
do you know where the sound is coming from? start the engine and lift the hood and see where it seems to be coming from. If all you changed was the battery, in my opinion, I would think its gotta be coming from that...
 

·
Registered
Joined
·
585 Posts
Discussion Starter #4
to me it sound like the upper area of the engine cuz when i stick my head under the hood that seems to be the strongest point
 

·
Registered
Joined
·
585 Posts
Discussion Starter #5
sorry also forgot to mention that its been sitting for 2 months or so because of the battery problem
 

·
Registered
Joined
·
3,411 Posts
tapping or pinging.... just curious to clear up what im thinking about loose lifters...
 

·
Registered
Joined
·
1,340 Posts
Olfordtruck said:
tapping or pinging.... just curious to clear up what im thinking about loose lifters...
I agree, is the noise tapping or pinging? There is a difference, tapping would suggest lifters or rockers, pinging would suggest timing. It's hard to describe the difference between the two, that's why I suggested a vid with sound.
Richard
 

·
Registered
Joined
·
3,411 Posts
yup yup! We tore down a 5.0 once in the mustang club because it was making odd tapping noises with bad mpg... turns out a valve was stuck open from too much carbon buildup and the piston was tapping it. Had to replace tons of internals because it threw a bunch of balanced stuff out of whack.
 

·
Registered
Joined
·
585 Posts
Discussion Starter #9
it was tapping but now i dont know what happend but its gone i started it every once in a while and today its gone soundds normal, but i havent tryied it on cold days yet it might start again on a cold day
but thanks guys for your help
,Dustin
 

·
Registered
Joined
·
1,340 Posts
I'd say it was a lifter. Should be fine.
Richard
 

·
Registered
Joined
·
3,411 Posts
yeah more thank likely a lifter.
 

·
Registered
Joined
·
585 Posts
Discussion Starter #12
should it be anything to worry about
 

·
Registered
Joined
·
1,340 Posts
alwaysFlOoReD said:
I'd say it was a lifter. Should be fine.
Richard
 

·
Premium Member
Joined
·
3,321 Posts
Yeah, I wouldnt worry about it too much. If the sound is gone, you probably just had something stuck.

You say you had the truck sitting for a while... how long was it? If it has been a few months, I would recommend changing the oil.
 

·
Registered
Joined
·
585 Posts
Discussion Starter #15
yea that was the first thing i did after starting it
 

·
Registered
Joined
·
1,321 Posts
white94ranger said:
hey guys i went out and finally found a deal on a optima red top battery for my truck, so mabey an hour ago i put it in and i started the truck and it started up fine put there was this pinging noise. what could this be from? right now with that noise it sounds like a desiel.
thanks Dustin
what is the noise?

I DoNt knoW
 

·
Registered
Joined
·
1,321 Posts
^^ sorry about that post, i was alittle drunk
 

·
Registered
Joined
·
1,321 Posts
Demon-FX4 said:
CaymanRanger said:
^^ sorry about that post, i was alittle drunk
not cool
i couldnt help it.. and i told him im sorry. done
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top