Ford Ranger Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
1995 ford ranger XLT 4X4
so my cruise control quit working at first it was intermittent now not working at all, after plenty of shotgun approaches and second guesses and trouble shooting, its come full circle to my newly place aftermarket LED lights not bulbs but the whole assembly,

NOW the question is does anyone else have this issue?? and where and how would i splice or place a load resister to get my cruise to working again??

if your cruise is not working check your bulbs yes this can stop it from working and or being intermittent

ANY HELP

thanks,
Robert
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
these are the tail lights I have put in
as they already have the load resistor where would I put the new ones, I have tried to buy the replacements but none are sold that I could find, (the gray little boxes not the lights).

WJ20-0021-02.jpg

WJ20-0021-02-a.jpg


1995 ford ranger XLT 4X4



so my cruise control quit working at first it was intermittent now not working at all, after plenty of shotgun approaches and second guesses and trouble shooting, its come full circle to my newly place aftermarket LED lights not bulbs but the whole assembly,

NOW the question is does anyone else have this issue?? and where and how would i splice or place a load resister to get my cruise to working again??

if your cruise is not working check your bulbs yes this can stop it from working and or being intermittent

ANY HELP

thanks,
Robert
 

·
Registered
Joined
·
2 Posts
More info please

Educate me on why LED lights would cause the cruise not to work and what the load resister would do to fix it? The load resister would cause a voltage drop lowering the voltage at the LEDs but how would that help the cruise?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
More info please

Educate me on why LED lights would cause the cruise not to work and what the load resister would do to fix it? The load resister would cause a voltage drop lowering the voltage at the LEDs but how would that help the cruise?

Got my cruise issue repaired,
found out that speed control cutoff switch was issue (the recall fire issue)

here is what I found

part number# Motorcraft SW6350
which says fits and works for the 1995 ford ranger 4.0 engine is "INCORRECT"
(after replacing this part three times)

part number# Motorcraft SW-6349 which says fits and works for the 1995 ford ranger is "CORRECT"
(after replacing this with CORRECT part one time)

SHOTGUN $ wasted to find this out

Cruise is working perfectly AGAIN after 2 years .......

hopes this helps someone else here searching for speed control (cruise control) issues
 
1 - 4 of 4 Posts
Top