Ford Ranger Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Well my truck is starting to make some strange noises. I started it up this morning and it was making a chirping noise not very loud though. My question is could this be the bearings in my water pump going bad? i do believe it has been leaking from the water pump not very bad though. I will post a video in the morning seems to do it only when cold. Very strange also has been making a ticking noise no idea where that is coming from either it's done that since i bought it so i am not to worried. Your help is appreciated Jeff.
 

·
Premium Member
Joined
·
3,321 Posts
Well, I think every Ranger I've had makes that noise when it's cold out (all 4 of them... LOL). I've learned to just ignore it. From what I can tell, it's either the fan belt or one of the pulleys.
 

·
Registered
Joined
·
4 Posts
First post so if I'm off topic or long winded just ignore me. You didn't mention the engine size but I just bought a 96 ranger with a 3.0L (upgraded from 95 2.3L) and the cam sychronizer bushings seems to be a very talked about problem with the 3.0 since when the bushings start squeaking its time to replace it. Seems they use the same gear to drive the oil pump. (the gear gets worn out and you know what that means when it fails) That's going to one of the first things I replace on mine since its got 232K on it and I have no maintenance records on it.
on the bright side, it could be the serpentine belt or belt tensioner . Just tossing out my 2cts worth.
 
1 - 3 of 3 Posts
Top